View
Posted about 2 years ago. Visible to the public.

Installing Rails 3.2 LTS

This document describes how to swap out the official Rails 3.2 gems with Rails 3.2 LTS. If you have installed Rails LTS before and want to update to a newer version, please see our update instructions.

Prerequisites

  1. Subscribe to a Rails LTS plan to receive your credentials. If you already have a paid subscription for another version of Rails LTS, you can use the same credentials for Rails 3.2 LTS at no additional cost.

  2. Make sure your project satisfies the system requirement for Rails LTS. This involves upgrading to the latest official Rails 3.2 release.

  3. Make sure that you have Bundler 1.10 or newer by running:

    Copy
    gem list | grep bundler

    This should show you a line like this:

    Copy
    bundler (1.10.6)

    If your version is lower than 1.10, you can update Bundler like this:

    Copy
    gem install bundler

    Please note that you need to have a compatible version of Bundler on all PCs that will be running your application (developer boxes, production servers, staging servers).

Installation

  1. Open the Bundler configuration file (Gemfile) in your project's root directory and find this line:

    Copy
    gem 'rails'

    Replace that line with the following code:

    Copy
    source 'https://username:password@gems.railslts.com' do gem 'rails', '~> 3.2.22' gem 'actionmailer', :require => false gem 'actionpack', :require => false gem 'activemodel', :require => false gem 'activerecord', :require => false gem 'activeresource', :require => false gem 'activesupport', :require => false gem 'railties', :require => false gem 'railslts-version', :require => false end

    Replace username and password with your personal credentials that you received after subscribing to Rails LTS.
    Make sure a colon (:) separates username and password.

    Note that our repositories are available via SSL (https) only, http://... will not work.

  2. Run Bundler to complete the installation:

    Copy
    bundle update rails

    If you're running ruby 1.8.7, you might get an error rake requires Ruby version >= 1.9.3. To resolve this, add the following line to your Gemfile:

    Copy
    gem 'rake', '< 11'
  3. Decide whether to enable optional security enhancements shipped with Rails LTS.

    In order to keep maximum compatibility to the official Ruby on Rails releases, Rails LTS disables all additional security features by default. We do however recommend the :hardened configuration, which includes improvements we believe to be reasonable defaults for increased security in most applications.

  4. Confirm that you are running the latest version of Rails 3.2 LTS.

  5. Follow your normal release process (run tests, push, deploy to staging, do smoke/whatever testing, deploy to production).

Congratulations! You successfully deployed your application using Rails LTS.

If you have chosen to subscribe to the Rails LTS Notification List when signing up, you will be notified whenever a new patch for Rails LTS becomes available.

Author of this card:

Avatar
Henning Koch
Last edit:
11 months ago
by Tobias Kraze
13 cards