View
Posted over 3 years ago. Visible to the public.

Updating Rails LTS to a newer version

This document assumes you have installed Rails LTS before and want to update to a new version of the Rails LTS gem. As a subscriber to the Rails LTS service, you will be notified whenever a new version for Rails LTS becomes available.

  1. If you have installed Rails LTS with Bundler, simply run the following comment within your Rails project directory:

    Copy
    bundle update rails

    If booting Rails now gives you this error:

    Missing the Rails 2.3.18 gem. Please gem install -v=2.3.18 rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.

    … then open config/environment.rb within your project directory and delete the following line:

    Copy
    RAILS_GEM_VERSION = '2.3.xx' unless defined? RAILS_GEM_VERSION

    If you have installed Rails LTS without Bundler simply repeat the installation process.

  2. Confirm that you are running the latest version.

  3. Follow your normal release process (run tests, deploy to staging, do smoke testing, deploy to production)

Congratulations! You have now successfully updated your application. If you have chosen to subscribe to the Rails LTS Notification List when signing up, you will be notified whenever a new patch for Rails LTS becomes available.

Author of this card:

Avatar
Henning Koch
Last edit:
over 1 year ago
by Henning Koch
Keywords:
upgrade, recent, release
13 cards