19 cards
View
Posted over 5 years ago. Visible to the public.

System requirements

Rails LTS has been conceived as a drop-in replacement for Rails 2.3 or Rails 3.2. However, we do recommend that you go through the list below to make sure that installing Rails LTS will work without problems.

Rails 2.3 LTS

Rails version

Your application should run the latest release of the official Rails 2.3 gems, currently (October 2015) version 2.3.18.

If you are running an earlier version, we strongly recommend upgrading to Rails 2.3.18 before installing Rails LTS.

Ruby version

Rails 2.3 LTS works with Ruby 1.8.7 out of the box.

We also support Ruby 2.3, however upgrading your Ruby version involves some manual steps.

RubyGems version

Rails 2.3 LTS requires RubyGems < 2. We recommend the latest 1.x release, which is 1.8.30 at the time of writing.

If you are using Rails 2.3 LTS with bundler you can also use current RubyGems versions.

ActiveRecord Database

Your ActiveRecord models should talk to one of the following databases:

  • MySQL (version 5.6)
  • PostgreSQL
  • SQLite3

While other database types might work with Rails 2.3 LTS, we only test against the databases listed above.

Rails 3.2 LTS

Rails version

Your application should run the latest release of the official Rails 3.2 gems, currently (October 2015) version 3.2.22.

If you are running an earlier version, we strongly recommend upgrading before installing Rails LTS.

Ruby version

Rails 3.2 LTS is tested against the following Ruby versions:

  • Ruby 1.8.7
  • Ruby 1.9.3
  • Ruby 2.3.3

While other Rubies might work with Rails LTS, we only test against the versions listed above.

Rails 4.2 LTS

Rails version

Your application should run the latest release of the official Rails 4.2 gems, 4.2.10.

If you are running an earlier version, we strongly recommend upgrading before installing Rails LTS.

Ruby version

Rails 4.2 LTS is tested against the following Ruby versions:

  • Ruby 2.1.7
  • Ruby 2.3.7
  • Ruby 2.5.1

While other Rubies might work with Rails LTS, we only test against the versions listed above.

Bundler version

Make sure that you have Bundler 1.11 or newer by running:

Copy
gem list | grep bundler

This should show you a line like this:

Copy
bundler (1.11.2)

If your version is lower than 1.11, you can should update Bundler.

If you are using Ruby 1.8.7 make sure that you install the latest compatible version:

Copy
gem install bundler --version=1.13.7

If you are using Ruby 2, you can install the latest version of Bundler:

Copy
gem install bundler

Please note that you need to have a compatible version of Bundler on all PCs that will be running your application (developer boxes, production servers, staging servers).

ActiveRecord Database

Your ActiveRecord models should talk to one of the following databases:

  • MySQL
  • PostgreSQL
  • SQLite3

While other database types might work with Rails LTS, we only test against the databases listed above.

All set?

If your application satisfies the requirements above, you should now subscribe to Rails LTS and upgrade your application.

If you are still unsure if your application is compatible with Rails LTS, send us an e-mail.

Owner of this card:

Avatar
Thomas Eisenbarth
Last edit:
23 days ago
by Tobias Kraze
Keywords:
compatibility
This website uses cookies to improve usability and analyze traffic.
Accept or learn more