System requirements

Rails LTS has been conceived as a drop-in replacement for Rails 2.3, 3.2, and 4.2. However, we do recommend that you go through the list below to make sure that installing Rails LTS will work without problems.

Rails 2.3 LTS

Rails version

Your application should run the latest release of the official Rails 2.3 gems.

If you are running an earlier version, we strongly recommend upgrading to Rails 2.3.18 before installing Rails LTS.

Ruby version

Rails 2.3 LTS works with Ruby 1.8.7 out of the box.

We also support Ruby 2.5, however upgrading your Ruby version involves some manual steps.

We do not support Ruby 1.9 for 2.3 LTS.

RubyGems version

Rails 2.3 LTS requires RubyGems < 2. We recommend the latest 1.x release, which is 1.8.30 at the time of writing.

If you are using Rails 2.3 LTS with bundler you can also use current RubyGems versions.

ActiveRecord Database

Your ActiveRecord models should talk to one of the following databases:

  • MySQL (version 5.6)
  • PostgreSQL
  • SQLite3

While other database types might work with Rails 2.3 LTS, we only test against the databases listed above.

Rails 3.2 LTS

Rails version

Your application should run the latest release of the official Rails 3.2 gems.

If you are running an earlier version, we strongly recommend upgrading before installing Rails LTS.

Ruby version

Rails 3.2 LTS is tested against the following Ruby versions:

  • Ruby 1.8.7
  • Ruby 1.9.3
  • Ruby 2.5

While other Rubies might work with Rails LTS, we only test against the versions listed above.

Rails 4.2 LTS

Rails version

Your application should run the latest release of the official Rails 4.2 gems.

If you are running an earlier version, we strongly recommend upgrading before installing Rails LTS.

Ruby version

Rails 4.2 LTS is tested against the following Ruby versions:

  • Ruby 2.1
  • Ruby 2.3
  • Ruby 2.5

While other Rubies might work with Rails LTS, we only test against the versions listed above.

Bundler version

Make sure that you have Bundler 1.11 or newer by running:

gem list | grep bundler

This should show you a line like this:

bundler (1.11.2)

If your version is lower than 1.11, you can should update Bundler.

If you are using Ruby 1.8.7 make sure that you install the latest compatible version:

gem install bundler --version=1.13.7

If you are using Ruby 2, you can install the latest version of Bundler:

gem install bundler

Please note that you need to have a compatible version of Bundler on all PCs that will be running your application (developer boxes, production servers, staging servers).

ActiveRecord Database

Your ActiveRecord models should talk to one of the following databases:

  • MySQL
  • PostgreSQL
  • SQLite3

While other database types might work with Rails LTS, we only test against the databases listed above.

All set?

If your application satisfies the requirements above, you should now subscribe to Rails LTS and upgrade your application.

If you are still unsure if your application is compatible with Rails LTS, send us an e-mail.

Thomas Eisenbarth about 7 years ago
This website uses short-lived cookies to improve usability.
Accept or learn more