20 cards
View
Posted about 1 year ago. Visible to the public.

RubyGems 2.x support for Rails 2.3 LTS

Starting with Rails LTS 2.3.18.19, it is possible to run Rails LTS with modern versions of RubyGems (2.6.13 at the time of writing) if you are using Rails 2.3 LTS with Bundler.

With RubyGems 2+, Rails LTS will restrict the following features which are now supplied by bundler:

  • You will no longer be able to use config.gem ... in environment.rb.
  • You can no longer freeze/unpack gems using rails:freeze:gems or rails:gems:unpack.
  • Rails will no longer search locally installed gems when looking for generators (in script/generate).

Owner of this card:

Avatar
Tobias Kraze
Last edit:
8 months ago
by Tobias Kraze
This website uses cookies to improve usability and analyze traffic.
Accept or learn more