Disable daemons / services in Mac OS X

Posted . Visible to the public.

WARNING: Before doing this, make sure you've tried uninstalling the related program first (if that's what you wanted in the first place). Also, try not using sudo first.

Look for .plists in the following folders:

/System/Library/LaunchDaemons/ - System-wide daemons provided by Mac OS X
/System/Library/LaunchAgents/ - Per-user agents provided by Mac OS X.
~/Library/LaunchAgents/ - Per-user agents provided by the user.
/Library/LaunchAgents/ - Per-user agents provided by the administrator.
/Library/LaunchDaemons/ - System-wide daemons provided by the administrator.

Assuming .plist is the daemon in question, do this in the command line:

sudo launchctl unload -w /path/to/.plist/<file>
sudo launchctl unload -w /System/Library/LaunchDaemons/<file>.plist

For example:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist
padi
Last edit
Posted by padi to Dev (2013-06-04 08:02)